Автор Тема: настройка IPTV от Ростелеком на роутере Netgear 3500L  (Прочитано 11042 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 4dmax

  • Авторитет
  • Пол: Мужской
Добрый день. Нужна помощь по настройке IPTV от Ростелеком на роутере Netgear 3500L. В теории вроде все представляю, но  мозгу не хватает все настроить.

Суть в следующем: От провайдера по шнурку приходит инет по PPPoE, но для самого интерфейса IP адрес провайдером не выдается. И при прямом подключении к компу винда присваивает IP из диапазона канальных адресов 169.254.0.0/16 и по этому интерфейсу без проблем приходит IPTV.

Когда же шнурок подключен к роутеру, то естественно работает только инет по PPPoE. Я так понимаю нужно присвоить WAN интерфейсу локальный IP (типа 10.0.0.1) и настроить маршрутизацию между ним и компом. Но это в теории.

На практике (если позволите немного истории) в стандартной прошивке последней версии нет поля для ввода локального IP, друзья с forum.netgear подсказали, что в прошлых прошивках такое поле было. Откатился, вписал туда локальный IP - все(инет и IPTV) заработало, но до поры до времени. Однажды, при такой конфигурации роутер начал жутко мигать всеми интерфейсами и перестал отвечать на внешние воздействия. Пришлось прописаный IP убрать. Я так понимаю возникала ситуация мультикаст шторма или вроде того.
Далее попробовал несколько альтернативных прошивок (типа Tomato, dd-wrt и прочих) благо роутер их официально поддерживает. Но там возможностей конфигурации еще больше и непонятно что и где прописывать в моей ситуации?
« Последнее редактирование: 13 Июля 2012, 11:12:09 от 4dmax »


Оффлайн point212

  • Модераторы
  • *****
  • Пол: Мужской
  • Мосс смотрит на вас...
Дело в том что IPTV приходит к тебе в виде широковещательных пакетов. Они рассылаются и принимаются всеми адресами в сети.
Поэтмоу при прямом подключении  компа к шнурку всё работает.

Но через роутер широковещательные пакеты не пролазят. По меньшей мере если об этом специально не позаботиться. Для решения сей проблемы роутер должен иметь спец.софт и/или поддержку протокола IGMP. Как правило всё это уже встроено в продаваемые на рынке девайсы.

Так что достаточно отыскать в веб-интерфейсе галочку IGMP или чего-нибудь про IPTV или Broadcasting; включить ее и хавать профит :)

Оффлайн point212

  • Модераторы
  • *****
  • Пол: Мужской
  • Мосс смотрит на вас...
http://zipleen.blogspot.pt/2010/10/howto-setup-netgear-3500l-using-tomato.html
Почитал инструкцию. Офигеть :) Встроенной поддержки нет. Но народ дружно делает хитрые хаки :)

Оффлайн 4dmax

  • Авторитет
  • Пол: Мужской
Почитал инструкцию. Офигеть :) Встроенной поддержки нет. Но народ дружно делает хитрые хаки :)
В том то и дело, что даже в стандартной прошивке есть поддержка IGMP proxy. Я думал что и в альтернативных это все так же есть, иначе зачем они. А таких инструкций, где все надо прописывать ручками, нагуглил целую кучу (и все разные ;D).

Так что достаточно отыскать в веб-интерфейсе галочку IGMP или чего-нибудь про IPTV или Broadcasting; включить ее и хавать профит :)
Простое включение галки IGMP proxy или всяких там multicast forwarding ничего не дает, так как провайдер не выдает ip адрес и перенаправлять просто нечего.

Вообщем, я так понял, что не удасться настроить тривиальную вещь на домашнем роутере, не став при этом професиональным сетевым админом. :)
« Последнее редактирование: 13 Июля 2012, 16:44:24 от 4dmax »

Оффлайн point212

  • Модераторы
  • *****
  • Пол: Мужской
  • Мосс смотрит на вас...
Да не нужен ему IP-адрес. Мультикаст приходит на все адреса. А IGMP так же работает через мультикаст :)
Так что вопрос "почему не работает" довольно объемен :)

И последняя твоя фраза вполне возможно что пророческая :)
Когда мне приходилось налаживать и тестировать работу мультикаста, моим другом и помошником на линуховом роутере были tcpdump, trafshow, iptarf :) Так что возможно, что для отладки придется все это взромоздить в ту вот маленькую коробочку и ковыряться.

Кстати инструкция, ссылку на которую выложил топкодер выглядит вполне здраво с точки зрения теории.

Оффлайн 4dmax

  • Авторитет
  • Пол: Мужской
Кстати инструкция, ссылку на которую выложил топкодер выглядит вполне здраво с точки зрения теории.
Да попробовал я уже. У меня как раз сейчас Tomato 1.28
На этапе настройки PPPoE инета(8 пункт), где он должен собственно появится, его нет. И никакого процесса pppoecd в списке процессов на роутере я тоже не наблюдаю(остальное все есть). Создавал все строго по инструкции. Видимо версия уже не та, поскольку все, что в инструкции чел создавал с помощью ssh, можно настроить и из под web, в разделе VLANS.